IP Address
What is an IP Address
IP address stands for Internet Protocol address. It’s a unique numerical label assigned to any device connected to a network that uses the Internet Protocol to communicate. Similar to a mailing address, just for your computer, phone, and any other device that you connect to the internet.
There are two types of IP addresses:
IPv4 - This is the older and more commonly used version. It is a group of four numbers separated by dots. For example: 192.168.1.1. Each number is between 0 and 255.
IPv6 - This is the newer version; we were running out of the older IPv4 version. It is a group of eight hexadecimal numbers separated by colons. For example: 2001:0db8:85a3:0000:0000:8a2e:0370:7334.
There are two main functions of an IP address. First, it identifies the host or network interface. Second, it identifies the location of the device on the network. When you go to a website, the IP address is used to find the website and connect to the server hosting the website.
You will also hear the terms “private IP address” and “public IP address.” The router has a public IP address. Devices on the network at home have private IP addresses.
Special use IPv4 Address Ranges
This list includes all IPv4 address ranges that are reserved, private, or used for special purposes (based on IANA and RFCs like RFC 1918, 6598, etc.).
| IP Range | CIDR | Name / Purpose | Routable? |
|---|---|---|---|
| 0.0.0.0/8 | 0.0.0.0 – 0.255.255.255 | “This host on this network” | ❌ No |
| 10.0.0.0/8 | 10.0.0.0 – 10.255.255.255 | Private (RFC 1918) | ❌ No |
| 100.64.0.0/10 | 100.64.0.0 – 100.127.255.255 | Carrier-Grade NAT (RFC 6598) | ❌ No |
| 127.0.0.0/8 | 127.0.0.0 – 127.255.255.255 | Loopback (localhost) | ❌ No |
| 169.254.0.0/16 | 169.254.0.0 – 169.254.255.255 | Link-local (APIPA) | ❌ No |
| 172.16.0.0/12 | 172.16.0.0 – 172.31.255.255 | Private (RFC 1918) | ❌ No |
| 192.0.0.0/24 | 192.0.0.0 – 192.0.0.255 | IETF Protocol Assignments | ⚠️ Mixed |
| 192.0.2.0/24 | 192.0.2.0 – 192.0.2.255 | TEST-NET-1 (Documentation) | ❌ No |
| 192.88.99.0/24 | 192.88.99.0 – 192.88.99.255 | 6to4 Relay (deprecated) | ❌ No |
| 192.168.0.0/16 | 192.168.0.0 – 192.168.255.255 | Private (RFC 1918) | ❌ No |
| 198.18.0.0/15 | 198.18.0.0 – 198.19.255.255 | Benchmark testing (RFC 2544) | ❌ No |
| 198.51.100.0/24 | 198.51.100.0 – 198.51.100.255 | TEST-NET-2 (Documentation) | ❌ No |
| 203.0.113.0/24 | 203.0.113.0 – 203.0.113.255 | TEST-NET-3 (Documentation) | ❌ No |
| 224.0.0.0/4 | 224.0.0.0 – 239.255.255.255 | Multicast | ❌ No (special) |
| 240.0.0.0/4 | 240.0.0.0 – 255.255.255.254 | Reserved for future use | ❌ No |
| 255.255.255.255 | — | Limited Broadcast | ❌ No |